Suggest your idea ...

remove trailling spaces when saving

Remove trailling spaces when pressing on CTRL+S

Could be an option of course :-)

33 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    lowanglowang shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    7 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • tigristigris commented  ·   ·  Flag as inappropriate

        I've added ctrl-s as the hotkey for the text bundle option to trim whitespace, but like others here the trimming happens AFTER the save, so the files saves but then the macro triggers E to think the file is again modified. Currently this is the ONLY thing i dislike about E, i hate trailing whitespace in my source

      • charlesroperAdmincharlesroper (Admin, E Text Editor) commented  ·   ·  Flag as inappropriate

        Yeah, you're right. It's only working intermittantly for me. Seems like an issue that could easily be fixed if Alexander were to queue the operations in the right order: make sure the command is run first, then the save. If I hit Ctrl-S a few times, then the * still hangs about, but the file does get saved.

      • lowanglowang commented  ·   ·  Flag as inappropriate

        Does not work neither. The spaces are removed, but the file remains unsaved (the star * is again here...).

      • lowanglowang commented  ·   ·  Flag as inappropriate

        When I do what you said, CTRL+S does not work anymore... OK, the trailling spaces are removed, but It doesn't save my file!!

      Feedback and Knowledge Base